Allegro.cc - Online Community

Allegro.cc Forums » Installation, Setup & Configuration » Opus with Allegro 5.2.5 binaries on Ubuntu

This thread is locked; no one can reply to it. rss feed Print
Opus with Allegro 5.2.5 binaries on Ubuntu
dthompson
Member #5,749
April 2005
avatar

I touched on this briefly in the release thread, but still can't get it to work.

Quote:

I'm getting Opus issues- harks back to NiteHackr in the 5.2.4 release thread. No linker errors though; just a failure to load the stream at runtime. I've got libopus0 and libopusfile0 installed.

Using -lopusfile -lopus doesn't seem to help, and ldd reports that my executable doesn't depend on either library. Am I missing something?

This isn't the case when linking with Ubuntu 18.04's stock Allegro 5.2.3.

When linking with Allegro 5.2.5 installed from the PPAs, ldd reports that libopus.so and libopusfile.so aren't required by the executable at all; this isn't the case with 5.2.3.

I can't see anything in the changelog about the way acodec's dependencies are linked.

Anyone have any ideas?

______________________________________________________
I'm on the web. You may have been told my domain was freakdesign.bafsoft.net, but these were lies.
This isn't a game!

SiegeLord
Member #7,827
October 2006
avatar

Hah, this is a simple one: I just didn't make the PPA packages depend on opus. I'll fix it this weekend.

"For in much wisdom is much grief: and he that increases knowledge increases sorrow."-Ecclesiastes 1:18
[SiegeLord's Abode][Codes]:[DAllegro5]:[RustAllegro]

dthompson
Member #5,749
April 2005
avatar

Ah, great. Thanks! :P

______________________________________________________
I'm on the web. You may have been told my domain was freakdesign.bafsoft.net, but these were lies.
This isn't a game!

SiegeLord
Member #7,827
October 2006
avatar

Should be fixed now.

"For in much wisdom is much grief: and he that increases knowledge increases sorrow."-Ecclesiastes 1:18
[SiegeLord's Abode][Codes]:[DAllegro5]:[RustAllegro]

Go to: