Allegro.cc - Online Community

Allegro.cc Forums » Programming Questions » Freetype Error Code 85

This thread is locked; no one can reply to it. rss feed Print
Freetype Error Code 85
pkrcel
Member #14,001
February 2012

Hi guys,
I was testing my freshly MSYS2 built Allegro lib with a simple project.

It always worked with pevious versions of this project, which I haven't modified.

I run into problems loading a font.

Looking with a debugger and then in the Allegro Log I see:

font     E D:_user\Pkrcel\coding\QTC_Projects\Allegro\addons\ttf\ttf.c:755  al_load_ttf_font_stretch_f       [  24.46295] Reading D:/_user/Pkrcel/coding/QTC_Projects/_oosb/build-Alleg-OOP-shooter/_resources/fonts/Carton_Six.ttf failed. Freetype error code 85

The font is there and it was usually loaded.

I ofund in Freetype reference

  FT_ERRORDEF_( Invalid_Stream_Operation,                    0x55, \
                "invalid stream operation" )
  FT_ERRORDEF_( Divide_By_Zero,                              0x85, \
                "division by zero" )

I don't know if the 85 is exadecimal or converted...

Where should I look to debig the operation? I actually don't know whats wrong.

Found!

Damn, I've built (with oh-so-much-sweat) a debug version of Freetype and found out that Init_Face failed due to "not a valid truetype font"...WTH? :o

Well, checking my Resources Directory I found that it gone mostly corrupt for some uninexplicable reason...restoring a backup did the trick but DAMN!

It is unlikely that Google shares your distaste for capitalism. - Derezo
If one had the eternity of time, one would do things later. - Johan Halmén

Go to: