Allegro.cc - Online Community

Allegro.cc Forums » Programming Questions » My exe is not working on a specific computer

This thread is locked; no one can reply to it. rss feed Print
My exe is not working on a specific computer
DrazeSwift
Member #15,229
July 2013

Hello,

I've recently started learning allegro 5 in addition to C++ and I am loving it. I've been following tutorials and eventually got to the point of where I made a simple space game. I was using Visual Studio Pro and used the setup wizard to create my setup.exe and my project.msi files. I used those files to install the game onto my computer and it worked fine, I installed it on my other computer which didn't have allegro 5 and it worked fine. However when I sent the two files to my friend they worked but when he tried to run the game.exe the program started in a "minimized" state and wouldn't maximize. I am at a loss for what the problem is. The only thing I could isolate down to possibly being an issue is the fact that the two machines that worked were windows 7 while his machine is windows 8, although I don't know what that means for me to be able to fix the problem.

Thanks in advance!

--Draze

Edgar Reynaldo
Member #8,592
May 2007
avatar

As a quick fix you can use ShowWindow :

#include <allegro5/allegro.h>
#include <allegro5/allegro_windows.h>

//...setup allegro and such and create your window

ALLEGRO_DISPLAY* display = al_create_display(width,height);
if (!display) {Fail();}

HWND window_handle = al_get_win_window_handle(display);

ShowWindow(window_handle , SW_RESTORE);

LennyLen
Member #5,313
December 2004
avatar

Also, try running one of the example programs on his computer.

Go to: