Allegro.cc - Online Community

Allegro.cc Forums » Installation, Setup & Configuration » How to install jpgalleg for allegro 4.4.2

This thread is locked; no one can reply to it. rss feed Print
How to install jpgalleg for allegro 4.4.2
Yashman
Member #13,582
September 2011

Hello everybody. I need some help. Could anyone give me a step-by-step instruction, how to istall jpgalleg for allegro 4.4.2? Thanks :)

GullRaDriel
Member #3,861
September 2003
avatar

Read the F***ing Manual provided with it ?

From memory it should be something like
fix.bat mingw32
make
make install

"Code is like shit - it only smells if it is not yours"
Allegro Wiki, full of examples and articles !!

Yashman
Member #13,582
September 2011

I read the instruction, but it's written there "Place the make.exe program in a directory pointed by your $PATH environmental variable and you're done.". I don't understand, where exactly I have to put the make.exe file ???

AMCerasoli
Member #11,955
May 2010
avatar

Set your Environment Variables as explained here

Yashman
Member #13,582
September 2011

Ok, I installed jpgalleg, but when I compile my project, compiler writes :
i:\gw\lib\crt2.o(.text+0x8) In function `_mingw_CRTStartup':
[Linker error] undefined reference to `__dyn_tls_init_callback'
[Linker error] undefined reference to `__cpu_features_init'
What's the matter?

AMCerasoli
Member #11,955
May 2010
avatar

Are you using an IDE?

If you do, you're not linking correctly to the MinGW compiler.

If you don't, I have no idea, since I have always used an IDE.

You could also have a mess of different compilers there... or something. If you're sign Code::Blocks you should have something like this:

{"name":"400px-Auto.jpg","src":"\/\/djungxnpq2nug.cloudfront.net\/image\/cache\/9\/c\/9c897c1c060a8faf888a76b969cdcbc3.jpg","w":400,"h":493,"tn":"\/\/djungxnpq2nug.cloudfront.net\/image\/cache\/9\/c\/9c897c1c060a8faf888a76b969cdcbc3"}400px-Auto.jpg

Edgar Reynaldo
Member #8,592
May 2007
avatar

Johan Halmén
Member #1,550
September 2001

Don't know what those linker errors are exactly, but usually they mean that you are missing the lib file. It might be at the right place on your hard disk, but your project doesn't include it.

I use Dev-Cpp for my Allegro 4 projects. After compiling the jpgalleg library, I've moved the libjpgal.a file to the /lib directory under C:/mingw/ and the jpgalleg.h file to the /include directory.

In my project settings (Project->Project options->Parameters->Linker) I include the line -ljpgal there. If you have a project setup for Allegro, you should have -lalleg there. Add -ljpgal there on its own line, before -lalleg.

In Code::Blocks I guess it's Project->Project build options->Linker settings and the frame "Link libraries:"

If you just use command lines, I guess you have to compare how the makefile is written for a normal allegro project, or how you write the command line. Where you see the -lalleg thing, add before it the -ljpgal thing.

If this doesn't work, I guess your compilation of the jpgalleg library has failed.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Years of thorough research have revealed that the red "x" that closes a window, really isn't red, but white on red background.

Years of thorough research have revealed that what people find beautiful about the Mandelbrot set is not the set itself, but all the rest.

Go to: