- Online Community Forums » Installation, Setup & Configuration » allegro compiles, but wont work

Credits go to BAF and Matthew Leverton for helping out!
This thread is locked; no one can reply to it. rss feed Print
allegro compiles, but wont work
Member #455
June 2000

I've installed allegro many times, and used it to make many games. this time, I get a streange problem after installing it on my laptop. The lib compiles fine with no complaints.

I have dev-cpp and allegro 4.20. on win xp sp2, on a laptop (800mhz, 256 mb ram)

I tried to recompile some games i made, but for somne reason, i got some wierd errors. So, I tried to run this test program to help me figure out the problem:

1#include <allegro.h>
2#include <stdio.h>
4int main(int argc, char** argv)
6 allegro_init();
8 // we are going to use 640x480 graphics mode
9 set_gfx_mode(GFX_AUTODETECT, 640, 480, 0, 0);
11 // install timer, mouse and keyboard
12 install_timer();
13 install_mouse();
14 install_keyboard();
16 clear(screen);
18 // display the mouse
19 show_mouse(screen);
21 exit(0); // succesfully exit

and i just like with my games, teh test program gives me errors:


Compiler: Default compiler
Building Makefile: "C:\zzztest\"
Executing make...
make.exe -f "C:\zzztest\" all
g++.exe -c main.cpp -o main.o -I"C:/Dev-Cpp/lib/gcc/mingw32/3.4.2/include" -I"C:/Dev-Cpp/include/c++/3.4.2/backward" -I"C:/Dev-Cpp/include/c++/3.4.2/mingw32" -I"C:/Dev-Cpp/include/c++/3.4.2" -I"C:/Dev-Cpp/include"

In file included from C:/Dev-Cpp/include/allegro/base.h:27,
from C:/Dev-Cpp/include/allegro.h:25,
from main.cpp:1:
C:/Dev-Cpp/lib/gcc/mingw32/3.4.2/include/stdarg.h:44: syntax error before `;'
C:/Dev-Cpp/lib/gcc/mingw32/3.4.2/include/stdarg.h:106: syntax error before `;'
In file included from C:/Dev-Cpp/include/io.h:36,
from C:/Dev-Cpp/include/allegro/platform/almngw32.h:23,
from C:/Dev-Cpp/include/allegro/internal/alconfig.h:45,
from C:/Dev-Cpp/include/allegro/base.h:40,
from C:/Dev-Cpp/include/allegro.h:25,
from main.cpp:1:
C:/Dev-Cpp/include/stdio.h:214: type specifier omitted for parameter
C:/Dev-Cpp/include/stdio.h:215: type specifier omitted for parameter
C:/Dev-Cpp/include/stdio.h:216: type specifier omitted for parameter
C:/Dev-Cpp/include/stdio.h:217: type specifier omitted for parameter
C:/Dev-Cpp/include/stdio.h:323: type specifier omitted for parameter
C:/Dev-Cpp/include/stdio.h:324: type specifier omitted for parameter
C:/Dev-Cpp/include/stdio.h:325: type specifier omitted for parameter

In file included from C:/Dev-Cpp/include/allegro/system.h:23,
from C:/Dev-Cpp/include/allegro.h:27,
from main.cpp:1:
C:/Dev-Cpp/include/allegro/unicode.h:93: type specifier omitted for parameter
C:/Dev-Cpp/include/allegro/unicode.h:93: parse error before `)'

make.exe: *** [main.o] Error 1

Execution terminated

ive never seen this problem before, what does this mean?


->Insert clever quote here<-
http:my website

Matthew Leverton
Supreme Loser
January 1999

Other people have had this problem, although there's never been a clear solution.

It would seem that Dev-C++ is not installed correctly. Perhaps you have mismatched components.

Member #2,981
December 2002

Wasn't/isn't the easiest solution to delete Dev-C++'s mingw, and install your own?

Member #455
June 2000

thanks for the help guys. After reading the other threads, I did what others did...installed dev-cpp4. It then worked. I didn't like the IDE, so i installed dev-cpp5 ( or something) on top of it without installing the compilers. So now i have dev-cpp 5 IDe with the working version of dev-cpp 4 and allegro.

->Insert clever quote here<-
http:my website

Go to: