Allegro.cc - Online Community

Allegro.cc Forums » Installation, Setup & Configuration » dev-cpp 4.9.7-gcc 3.2 missing bit/c++config.h

This thread is locked; no one can reply to it. rss feed Print
dev-cpp 4.9.7-gcc 3.2 missing bit/c++config.h
kazzmir
Member #1,786
December 2001
avatar

I just tried to compile something that included <vector> and dev-cpp 4.9.7 with mingw32 gcc 3.2 complained that it didnt have <bits/c++config.h>. I had to erase it and install dev-cpp 4.9.7 mingw32 gcc 2.95. The 2.95 version compiled it fine. Should i report this as a bug somewhere or something? Are there any other bugs like this in dev-c++?

Pradeepto Bhattacharya
Member #1,340
May 2001

:)
Hey thats the bug....it is mentioned in the d/l page of DevCpp .That bug is only there with 3.2 version of Dev Cpp as they are changing some Win API or something.You couldn't have missed the notices it is in CAPS and bold.
I d/led latest DevCpp yesterday with 2.95 gcc .Man I likethis DevCpp 5 it rocks.Self update checks and updates.Man it is something since Ihad seen it for the first time about 2 years ago I think.

Only one thing,how to get that CVS thingy work??Whenever I click on login or anything else in CVS menu I get a Message that "Please configure CVS Tools/Environments ".There is hardly anything to do there except for Compression level and a path.
Am I supposed to d/l something else like WinCvs or alike.
Can someone shed some light on the same.Thanx

--
I vote for Pradeepto. - Richard Phipps
Hey; Pradeepto's alive! - 23yrold3yrold

gillius
Member #119
April 2000

You have to copy the include/c++/mingw/bits directory down a level into include/c++, to merge the include/c++/bits directory with include/c++/mingw/bits.

c:\dev-cpp> copy include\c++\mingw\bits*.* include\c++\bits

Gillius
Gillius's Programming -- http://gillius.org/

Goalie Ca
Member #2,579
July 2002
avatar

thanks, i was having that problem too. I thought i had a syntax error causing problems all the way down (which has happened before :P)

EDIT:
I'm getting a new problem now :D
it doesn't like the allegro "c" code very much :(

EDIT2:
I tried extern "C" and wrapped that around the allegro.h include file, now its whining about overloaded functions. Ugg :(\

EDIT3:
Removed all that, put ANSI "C" support on, and now i'm getting less errors but still within allegro headers.

I'm using 4.17. Compiles perfectly with c code.

-------------
Bah weep granah weep nini bong!

Go to: