Allegro.cc - Online Community

Allegro.cc Forums » Installation, Setup & Configuration » Which compiler should I download?

This thread is locked; no one can reply to it. rss feed Print
Which compiler should I download?
Appledog
Member #16,747
September 2017

Hi. I tried to download the latest version of MinGW, which has compiler 6.3.0 in it. However, the Allegro files I have are for 6.2.0. This seems to be causing a problem where al_clear_to_color(al_map_rgb(0, 0, 0)); crashes.

Can someone please give me the exact version of MinGW I need to download? Yes 6.2.0, but, dwarf? posix? sjlj? win32? seh? rev0 or rev1?I have no idea what is going on. I just need a link for a compiler that works with the Allegro5 binaries.

In the meantime I will keep trying to compile Allegro5 on windows, but this has taken me several days to try and figure out and I am kind of exhausted from it. I hope someone can help, thanks.

Edgar Reynaldo
Member #8,592
May 2007
avatar

The official binaries and dependencies were compiled with 6.2 which was current at the time, but since then 6.3 has come out.

My binaries are compiled with MinGW-W64 gcc 7.3.0 and I provide a link to the correct version of MinGW to download as well.

Get them here :
https://www.allegro.cc/forums/thread/616935

SiegeLord
Member #7,827
October 2006
avatar

The ones on github are posix+dwarf for 32 bits, posix+seh for 64 bits. Revision doesn't matter.

"For in much wisdom is much grief: and he that increases knowledge increases sorrow."-Ecclesiastes 1:18
[SiegeLord's Abode][Codes]:[DAllegro5]:[RustAllegro]

Appledog
Member #16,747
September 2017

Thanks for your help guys, things are working very well now.

Go to: