- Online Community Forums » Programming Questions » Libgcc_s_dw2-1.dll Missing Follow up

This thread is locked; no one can reply to it. rss feed Print
Libgcc_s_dw2-1.dll Missing Follow up
Member #13,038
July 2011


I got my static build to work. It’s one of those things where I’m not 100% sure what exactly fixed it as I was changing different things here and there as I went.

Previously I tried Dev-Cpp that was supposed to be portable but wasn’t specifically packaged to work with the menu app. I tried everything such as your mingw recommendation, your Allegro upgrade, various static command prompt configurations, changing PATH directories in numerous locations, using the list of libs your recommended, even entered in the lib files and location for each in the linker section. Nothing.

I did the same with Eclipse Helios, and Code:blocks. No luck. Code:block eventually would compile a hello world program. On my program however, it kept losing the lib directory and include directories. I had to update them every time I opened Code:Blocks. Was really disappointed about Eclipse as I do most of my programming in it in Slackware.

In any case, once again I deleted all the IDEs and copies of Mingw. I downloaded
It installed though PortableApps and initially worked for Yo World type programs but still gave me errors for Allegro. So I replace the mingw 64 that came with it, with your
and once I install the Allegro 4.4.3 files, updated my paths within DevCpp, I added your lib list to the linker and -static-libstdc++ -static-libgcc to the compiler and it compiled my static program no problem.

I’ve since tried my game on three Win 7 machines. Worked fine, and a Vista machine. Was a touch slower but did fine. I’m going to clean up a few small things, bundle the files, and maybe write a short README file and call it quits. At that point it is what it is ;D.

Thanks for all the help

Edgar Reynaldo
Member #8,592
May 2007

With Code::Blocks, you create a project file.

Glad to see it's decided to work for you.

Go to: