Allegro.cc - Online Community

Allegro.cc Forums » Allegro Development » Fullscreen Window Issues

This thread is locked; no one can reply to it. rss feed Print
Fullscreen Window Issues
thebignic
Member #14,419
July 2012

Windows 32bit app using OPENGL.
Allegro 5.1.13

Fullscreen window often seems to open up on the wrong screen or just off screen on some laptops that have a 2nd output, even if its not enabled.

Is this issue fixed in later builds (after 5.1.13)?

Anyone know why the later builds dont seem to have any OpenGL stuff defined?

Elias
Member #358
May 2000

thebignic said:

Anyone know why the later builds dont seem to have any OpenGL stuff defined?

What is the first error you get?

--
"Either help out or stop whining" - Evert

thebignic
Member #14,419
July 2012

Error (active) identifier "glActiveTexture" is undefined
Error (active) identifier "GL_TEXTURE1" is undefined
Error (active) identifier "glGetUniformLocation" is undefined
Error (active) identifier "GL_TEXTURE_3D" is undefined
Error (active) identifier "glUniform1i" is undefined
Error (active) identifier "glActiveTexture" is undefined
Error (active) identifier "GL_TEXTURE1" is undefined

Can anyone confirm or deny that the Fullscreen opening on wrong (or invisible) monitor is fixed in 5.2.x?

I'm grasping at straws here. I have a regular windowed version of the game running but whenever I toggle to fullscreen window, it either goes off the screen partially or completely and cannot be found on any active monitors.

This only seems to happen on mobile hardware with integrated graphics but other games are apparently not afflicted by this so I'm very curious about this. I've read plenty of posts about how its just supposed to work but...

Go to: