Allegro.cc - Online Community

Allegro.cc Forums » Installation, Setup & Configuration » Problems with Visual Studio Community 2017

Credits go to SiegeLord for helping out!
This thread is locked; no one can reply to it. rss feed Print
Problems with Visual Studio Community 2017
NeoFahrenheit
Member #16,644
March 2017

Hi. I installed the NuGet Package Manager in my VS 2017, opened the console and typed 'Install-Package Allegro'. It was a C/C++ Empty project (Win 32 Console Aplication), then a created a *.c file on 'Source'.

But, all the test codes I found online, none of them work!

I've attached some pictures with the erros messages.

Thanks. :)

Update: Follow this tutorial. Didn't work either:
https://wiki.allegro.cc/index.php?title=Windows,_Visual_Studio_2015_and_Nuget_Allegro_5

Upload the problems.jpeg and problems2.jpeg files with errors using the tutorial above.

SiegeLord
Member #7,827
October 2006
avatar

The Nuget package needs to be updated to support MSVC 2017. I'll do it this weekend.

"For in much wisdom is much grief: and he that increases knowledge increases sorrow."-Ecclesiastes 1:18
[SiegeLord's Abode][Codes]:[DAllegro5]:[RustAllegro]

NeoFahrenheit
Member #16,644
March 2017

Thanks so much!
I'll wait, then. :)

Will you post here when the update is done?

SiegeLord
Member #7,827
October 2006
avatar

It is now done. The package version 5.2.2.1 supports MSVC 2015 and 2017 (I dropped 2013 support to limit the size of the package).

"For in much wisdom is much grief: and he that increases knowledge increases sorrow."-Ecclesiastes 1:18
[SiegeLord's Abode][Codes]:[DAllegro5]:[RustAllegro]

torhu
Member #2,727
September 2002
avatar

I think supporting MSVC 2008 is more important than supporting the 2010 and upwards versions, except the one or two latest versions. 2008 was the last good version of MSVC, and it's not likely to come back as long as the competition is Java-based.

SiegeLord
Member #7,827
October 2006
avatar

Does MSVC 2008 have a free version?

I'm not sure why one would want to stick with an outdated C/C++ compiler, however. If one was unhappy with the modern MSVC offerings, I imagine a more logical step would be to just switch to the OSS alterantives that at least let you use modern C/C++ features (e.g. modern MSVC's support quite a bit of C99, it's great).

"For in much wisdom is much grief: and he that increases knowledge increases sorrow."-Ecclesiastes 1:18
[SiegeLord's Abode][Codes]:[DAllegro5]:[RustAllegro]

torhu
Member #2,727
September 2002
avatar

SiegeLord said:

Does MSVC 2008 have a free version?

There's a "C++ Express" version, don't know if you can still get hold of it.

The C++ compiler is outdated, but it's fine for C. I guess big, slow IDE's is what's available now. You could always use an editor and Makefiles with the M$ tools...

tobing
Member #5,213
November 2004
avatar

I'm using 2013 and 2015, and I find that 2013 is quite OK. Fast enough, and a lot of nice compiler features for more advanced C++ - though it doesn't implement all of the standard, as far as I understand. There's a 2013 community edition as well.

Arvidsson
Member #4,603
May 2004

Yeah VS2015 is very nice and 2017 seems to as swell. Have mostly used it for C# though, but have never found it slow really.

NeoFahrenheit
Member #16,644
March 2017

Thanks so muck.
It works perfectly now. :)

Steve Terry
Member #1,989
March 2002
avatar

VS2017 now with twice the telemetry hooks ;D

___________________________________
[ Facebook ]
Microsoft is not the Borg collective. The Borg collective has got proper networking. - planetspace.de
Bill Gates is in fact Shawn Hargreaves' ßî+çh. - Gideon Weems

Neil Roy
Member #2,229
April 2002
avatar

I have VS2013. I tried 2015 and there was something I didn't like about it. I forget now. I'm on Windows 7 as well. Doesn't really matter as I rarely use Visual studio anyhow.

Never tried 2017, how is it with Windows 7?

I'll most likely stick with Code::Blocks in the meantime as I like pure C code.

SiegeLord
Member #7,827
October 2006
avatar

I use Win 7 and as far as I tried it, MSVC 2017 seems to work fine with it.

"For in much wisdom is much grief: and he that increases knowledge increases sorrow."-Ecclesiastes 1:18
[SiegeLord's Abode][Codes]:[DAllegro5]:[RustAllegro]

Neuton Mouse
Member #15,146
May 2013
avatar

Okay, i tried latest allegro nuget package on 2015 and i got some issues with it.

First, for some reason it reports this stuff:

packages\Allegro.5.2.2.1\build\native\Allegro.targets(255,5): error MSB3030: Could not copy the file "allegro-5.2.dll" because it was not found.

Well, no problem, i'll do the copies manually. So, i removed the copy lines in "Allegro.targets" and launched the application. Now, it wants "allegro-5.1.dll" for some reason :)

So, is something i'm missing?

SiegeLord
Member #7,827
October 2006
avatar

Hmm, I just tried making an new project in 2015 and also upgrading an existing one and everything seemed to work fine. Not to say that it isn't the packages fault, but perhaps try reinstalling it or something? The 5.1.dll bit is completely beyond me (do you have manual linker options set)?

"For in much wisdom is much grief: and he that increases knowledge increases sorrow."-Ecclesiastes 1:18
[SiegeLord's Abode][Codes]:[DAllegro5]:[RustAllegro]

Neuton Mouse
Member #15,146
May 2013
avatar

I wasn't aware of tutorial, so setting "Library Type" in project settings fixed this problem. If it's blank null then it asks for Allegro5-1. Don't know why.

The thing i never had exactly this name mentioned before and it just pops out asking for 5.1 version out of nowhere. No manual options in linker.

Overall, that nuget package is sure amazing thing, thanks for making it there.

Neil Roy
Member #2,229
April 2002
avatar

I installed VS2017 on Windows 7-64bit and installed Allegro 5 on it without problems (aside from my lack of familiarity with Visual Studio) under NuGet and managed to get it running with the tutorial.

With that said, I think I still prefer CodeBlocks. VS is still a convoluted mess in comparison. At least for me. I may play with it some more to see if I can get used to it.

Go to: