Running Allegro aplications on Android

Hi, I been trying to test Allegro on an Android device but:

I tried following the wiki and when I run (Using MSYS):
At the end couldn't find: ZLIG, PNG, JPEG, PkgConfig, Webp, OpenAL, OPENSL, FLAC, DUMB, OGG, Freetype, PhysFS, PHYSFS, ZLIG, ENET, LATEX.
It doesn't build ex_: color, depth_mask, haptic2, physfs, video, font_justify, font_multiline, logo, projection, ttf, audio_chain, synth.
It says that because ENET isnt find it doesn't build test.
At first it didn't find d3d9 either but I apply the answer of SiegeLord ont the post from 12/16/2017 export DXSDK_DIR=...

I tried following the README_android.txt and when I run (Using MSYS):
cmake .. -DCMAKE_TOOLCHAIN_FILE=../cmake/Toolchain-android.cmake -DCMAKE_BUILD_TYPE=Debug -DANDROID_TARGET=android-15 -DARM_TARGETS=armeabi-v7a -G "MSYS Makefiles"
It stops saying:
CMake Error at CMakeLists.txt:17 (project)
c:/"path to toolchain"/bin/arm-linux-androideabi-clang.exe
is not a full path to an existing compiling tool.
The same happens with CMAKE_CXX_COMPILER

And I also tried with the binaries for Android Studio by allefant on Github, here the setup goes well, but when I modify the Main Activity to load the allegro libraries (setp 4 of the Readme) it does compile but when open the aplication in the smartphone it stop working with the logcat saying:
A/libc: Fatal signal 11 (SIGSEGV), code 2, fault addr 0xa3c75fd8 in tid 31812 (trampoline) after the OnResume from AllegroActivity

Hope you can tell me whats the right method to deploy for Android, or how to solve the issues.

Edgar Reynaldo

Bumping for lock prevention.

Elias is your best bet for getting help on Android. You can catch him on IRC on Freenode on #allegro.


Can you get the logcat output from when it crashes?

Thread #617196. Printed from