[TINS] Voting Hurdles

Hey all! I got really busy with things after the competition and haven't had a chance to sit down and properly review all the games.

I'm having some troubles getting things to work in a Mac environment. I've got a Windows 10 virtual environment setup via VirtualBox. This allowed me to play entheh's entry. I got SiegeLord's entry working on Mac. I can't get Allefant's or Amarillion's to work. I didn't do any allegro setup on this virtual environment which might be the problem.

Images attached of the errors I'm getting. Thoughts?

Chris Katko

Sounds like a path or permissions issue if it can't find/open a file. Try running administrator / in a different folder? Make sure there are no spaces in folder paths? (Doesn't look like there are.)

Anyone got a link to those win binaries? I never tested them so I can test on my machine if you want.


Thanks, Chris. Good thoughts. Unfortunately, it didn't work. The windows binary pack is in the depot if you want to try it out. :(

I reviewed the games I could and gave a base score for the others that I wasn't able to review.


Here's an OSX bundle for Dr. Forest: https://www.dropbox.com/s/jqpmq5n7vujjgy2/DrForest.zip?dl=0

I had a bit more trouble with Peppy Peptide Puzzle on the account of it using shaders, and that interacting oddly with OSX, but I am sure I can resolve it, just not this second (a bit late here, hah!). I'm getting pretty good at this OSX compilation thing 8-).


It's too bad you had trouble compiling my entry. I've never tried compiling any of my games on a Mac, and I don't have one laying around either. So I'm afraid I can't help you very much.


And here's Peppy Peptide Puzzle: https://www.dropbox.com/s/iuleclxjtgpg1uw/PeppyPeptidePuzzle.zip?dl=0

Here are the changes I had to make for this one:

- Switched to using al_run_main instead of the main addon. It's just more reliable, in my experieince.
- The main hurdle was the shader. First, I removed the #version 130 statement, as that caused it to not compile. This is likely an Allegro issue somehow (or maybe one needs to set some special display flags?)
- The shader read from gl_FragColor, which I don't think is valid. I replaced it with varying_texcoord scaled by the bitmap dimensions, and that worked great.


Hey, any chance you can share the fixed source code back? Then I'll add the fixes to the next version.

edit: By the way, gl_FragCoord is available from GLSL 1.10:

Perhaps 1.30 is not supported on OS X, but earlier versions are. Perhaps it can be made to compile with #version 120 or #version 110.

Thread #617145. Printed from Allegro.cc