[BUG] Problem with KDE Plasma Panel
Victor Savcenco

Hello, to be honest, I'm not sure where to ask this, here or KDE, but here's what's happening, when I run an allegro5 powered application the KDE Panel messes up, until I turn that app off. The task manager goes crazy, opened apps change, it's like they get rewinded, like, chrome went back to when there was an empty tab and Amarok reappeared even though it was closed (in background), terminal went back to when I was compiling the game and our allegro game hides behind one of the apps and the clock freezes, maybe more that I did not notice. But it is only visual, in reality everything is fine, like if I hover it's the right apps in right place, even though visually everything is wrong. It happens every time I run my project and I got same results with Factorio, while other games do not do that, like SDL2 powered FTL or Java Project Zomboid.

I use Fedora 26 KDE Spin, X Server, more can be seen in the screenshot. Allegro library I use is Allegro 5.2.0, compiled from source in monolith mode.

I cannot tell if I'm the only one with this issue or it happens for every KDE user, because it's the only computer I have with KDE on it, rest are GNOMEs where this does not happen (Dash2Dock, Dash2Panel).

I attached screenshots of problem before and after and system information.

Thank you in advance.

SiegeLord

Are your Allegro displays fullscreen or windowed?

Victor Savcenco
SiegeLord said:

Are your Allegro displays fullscreen or windowed?

Windowed, but I just tested Factorio in fullscreen, and same effect, although it seemed to be "borderless fullscreen windowed" mode.

---

Alright, just tested out my game in fullscreen, and the problem persists, so yeah, it happens in both windowed and fullscreen modes.

Also, I don't know if it is important, but I have 4 monitors and the panel is only on one of them. On which monitor is Allegro window does not matter, it happens anyway, and I tested out in fullscreen on another monitor and on same monitor and it still happens.

SiegeLord

Please try compiling Allegro with the attached patch, and trying again. I couldn't exactly reproduce your issue (I tried it on Fedora in a VM), but playing around with things I do observe that Allegro turns off compositing when it creates a display, which kind of sounds like what you're observing.

As an additional experiment, you could manually try to disable compositing (Ctrl-Shift-F12), and see if that reproduces this issue independently from Allegro. Alternatively, disable compositing and try running un-patched Allegro while compositing is off, and see if it has the same effect.

Victor Savcenco
SiegeLord said:

Please try compiling Allegro with the attached patch, and trying again.

Yes! That worked like a charm. Now everything works as expected. Thank you very much for help!

I've attached a screenshot of it in action. I did not try disabling compositing since patched allegro worked.

SiegeLord

Ok. So the actual bug is indeed on KDE's side, so you can submit it there if you want. The way we'll address it in Allegro is that we'll add a configuration option for this. By default, it'll still disable compositing for fullscreen, but for windowed I think it makes sense to keep compositing on. I added a bug for it so we don't forget: https://github.com/liballeg/allegro5/issues/818

Victor Savcenco

Great! That makes sense to add an option for it. I'll post it on KDE and will see how it goes. Thank you!

Thread #617018. Printed from Allegro.cc