Allegro build error
Dogtronic

Hi there.
Following this guide
https://wiki.allegro.cc/index.php?title=OSX,_Xcode_5,_dylib
I come to an error at step 5.
Any help/advice would be greatly appreciated

1. [done] git clone https://github.com/liballeg/allegro5.git
2. [done] cd allegro

3. [skipped] git checkout 5.0

4. [done] cmake -G Xcode - ..

5. [failed] xcodebuild

allegro5/addons/audio/openal.c:12:10: fatal error: 'OpenAL/al.h' file not found
#include <OpenAL/al.h>


Additional information 

** BUILD FAILED **


The following build commands failed:
	CompileC build/addons/audio/ALLEGRO.build/RelWithDebInfo/allegro_audio.build/Objects-normal/x86_64/openal.o addons/audio/openal.c normal x86_64 c com.apple.compilers.llvm.clang.1_0.compiler

Polybios

You are missing the OpenAL dependency. Allegro's addons need quite some dependencies to do their work (it is mentioned in the article you use).

You could get these dependencies via homebrew, for example. But then you could also just install Allegro5 itself via homebrew ("allegro" formula), without compiling yourself.

Unfortunately, the wiki does not seem to be up-to-date with this, sorry.

Edgar Reynaldo

The wiki is open for editing. Feel free to fix it if you know what you're talking about. ;)

Dogtronic

Polybios - just used the brew install
all is good
thanks

Polybios

The wiki is open for editing. Feel free to fix it if you know what you're talking about. ;)

I still don't have a Google account and I currently don't intend to get one.

Thread #616953. Printed from Allegro.cc