makefile.all:248: *** recipe commences before first target. Stop.
coderthatcancode

Hey guys, I'm new to the allegro community as well as allegro4 and I went through the codeblocks allegro installation (https://wiki.allegro.cc/index.php?title=Code::Blocks) and I came across this problem, I installed directX and mingw (accept it was TDM-GCC-32, which is updated. Not sure if this could be the problem)

I got the command prompt out to install allegro:

Quote:

FIX.BAT mingw

Configuring Allegro for Windows/MinGW...

Quote:

MINGW32-MAKE.EXE

makefile.all:248: *** recipe commences before first target. Stop.

Please help, but keep in mind I am aware of the allegro5 but I prefer the allegro 4 library please help!

I really don't know how to come across this. Thanks

Sincerely coderthatcancode

Edgar Reynaldo

That guide is severely out of date. And the wiki is read only for on going maintenance.

You want to use MinGW(64), CMake, and Allegro 4.4.3 from GIT to build allegro 4.

coderthatcancode

+Edgar Reynaldo Thank you ever so much for replying, but please, guide me by sending the links. I'm not really sure where to get this but I appreciate the response.
I'm using windows vista, is this good too?

Edgar Reynaldo

I think I have an easier solution. If you want, you can use my premade mingw 5.3.0.3 and allegro 4.4.3 binaries. Find them in the top post in the thread linked below.

https://www.allegro.cc/forums/thread/616785

coderthatcancode

+Edgar Reynaldo So this is already made? if so, how do you install, and what would you do with it for codeblocks.

Edgar Reynaldo

You need 7-zip to unpack the archives I provided. If you extract both of them twice you will end up with a mingw folder and an allegro folder.

Copy the mingw folder to c:\ and leave the allegro folder where it is. To use the mingw compiler you need to set your PATH environment variable. You can do that through MyComputer->Right click->Properties->Advanced System Settings->Environment variables or you can do it like this :

Put this in a .bat script and run it whenever you need to use MinGW :

set path=c:\mingw\bin;%PATH%

Either way, you need to add mingw\bin to your PATH.

After that create a new CodeBlocks project and add your files to it. Next you will need to configure your project. Go to Menu->Project->Build Options and select the main project on the upper left. Go to the Search Directories tab and select Compiler. Add a new entry that points to allegro/include. Go to the Linker search directory tab and add a new entry that points to allegro/lib. Next go to the linker settings tab and add the libraries that you will be using to your linker options or add them to link libraries.

After that you should be good to go.

Hope this helps. Sorry for the delayed response.

Edgar.

Thread #616915. Printed from Allegro.cc