URGENT need help font problem
duncan perham

Sorry for double post, but I really need some help in sorting out this font issue. On some machines all the fonts are missing some characters.
However on over a dozen machines winxp, win 7 win8 and win 10, the problem is not present.

I am not sure of exact cause as I have tried numerous graphic cards and every OS, its works perfect on every machine i have.

The game lauches on steam in 7 hours, quite a lot of people may be affected by this.


Have you tried explicitly using the GL backend?

duncan perham

How do you do that?


Just bitwise OR ALLEGRO_OPENGL to your new display flags:

      flags |=  ALLEGRO_OPENGL;

Edgar Reynaldo

al_set_new_display_flags(ALLEGRO_OPENGL | ...);

Or there is a way to change it using allegro.cfg, but I don't know how.

As I mentioned in the other thread, try updating your allegro if it is not the most recent version.


I've implemented a workabout for a missing characters in a TTF font issue (possibly same issue as yours) in this pull request: https://github.com/liballeg/allegro5/pull/562

To use it, you'll obviously have to rebuild Allegro (I can help you out with that if you need help), and then add this to your code before you load TTF fonts:

al_set_config_value(al_get_system_config(), "ttf", "lock_whole_page", "true");

duncan perham

Thanks for the response, I will look into those things. Big problem at the moment is I cant find a computer that I can test it on where the text is missing. So its a bit difficult to know if Ive fixed it or not.

First thing I will do is try to get it updated as much as possible.

Thread #616008. Printed from Allegro.cc