Grabber.exe compiled with Allegro 3.1


Does anyone still got a copy of Grabber.exe compiled with Allegro 3.x (located in allegro\tools\grabber.exe)

Thank you so much in advance.

Question: Why ?
Answer: (This is the sequel to the previous thread )
I'm trying to run a very old Allegro program I made.
I was using ".dat" files made with grabber and Allegro 3.12.
However I only have a grabber.exe tool compiled with Allegro 4.0, and I suspect that it works differently from grabber.exe compiled with Allegro 3.1 thus "corrupting" some part of the dat, which make it anreadable for an Allegro 3.1-compiled executable.


I once salvaged data from a 3.x game with a 4.x grabber and it mostly works using the grabber utility. Be sure to make a backup of the .dat file just in case...


I did backups.

What I tried is to open with Grabber 4 (ie: the grabber.exe compiled with Allegro 4.x) a dat file previously created with Grabber 3 (the grabber.exe compiled with Allegro 3.x)
The openning of the dat file works.
All inner data seems correct (according to previews).
However if that Grabber 4 saves the dat file, it is not recognized anymore by my Allegro 3.x executable.

This "corruption" happens only if the DAT file contains fonts.
It seems to work fine otherwise.
Fonts seem to be encoded differently in Allegro 3 and 4.

That's why I would like to find a copy of Grabber 3.

Thank you

Peter Hull

Let's party like it's 1999!
Allegro 3.1.2 compiled with DJGPP/gcc 4.7.3


Arthur Kalliokoski

Let's party like it's 1999!

The image looks more like something from 1982, but whatever...


Allegro 3.1.2 compiled with DJGPP/gcc 4.7.3

What did you have to tweak to manage that?

Peter Hull

What did you have to tweak to manage that?

More than I anticipated :(


Thank you so much! I will let you know if it solves my problem!

hmmm. It seems that the dat file fails being read correctly with Grabber 3 (under DosBOX)
All headers are here but it is previewed as gibberish.
And saving the dat file crashes.

I think I will load the dat file using grabber 4, export all items.
And import them all in grabber 3.
I hope it will run...


If you have access to the original source code, I believe you can recompile with Allegro 4 with minimal (or maybe no?) changes. (The v3 to v4 switch was so long ago that I could be mistaken on this one though.) That might be an easier solution to your problem.

It's been a long time since I've worked with Allegro's datafiles, so my memory is hazy. But I believe that you want to avoid changing the ordering of the contents, as that will render it corrupt from the point of view of your pre-compiled program.


If you keep trying with the grabber, be sure to run it in the right color depth, according to your needs.
ie. "grabber -8 mydata.dat" if your game is 256-color.

Have you tried with the dat.exe utility instead ? It may let you do your changes, even if the problem is still not explained.

Troubleshooting may be easier by loading+saving the datafile, and performing a binary diff : The file format is not supposed to have changed, so the first byte where there is a difference is already a problem.


Here is my "progression" so far...

  • Under DOSBox: load using GRABBER3 in 8bit : grabber.exe -8 mydata.dat ==> still preview gibberish and crash when saving.

  • Under DOSBox: use DAT utility (DAT4, compiled with Allegro4) : dat -pal F00 -u abcd.dat F01 ==> still corrupting the dat file, like GRABBER4 does. I have checked: The 1st 'corrupted' byte correspond to a FONT...

I assume that, to try DAT utility solution, I'll need DAT3 (DAT compiled with Allegro 3.12)

Can someone provide me such exe please ?
Thank you

Thread #615598. Printed from